Watch, Follow, &
Connect with Us
Public Report
Report From: Delphi Prism/Debugger    [ Add a report in this area ]  
Report #:  94337   Status: Need Feedback
Can't evaluate pointers in VS 2010
Project:  Embarcadero Prism Build #:  4.0.25.791
Version:    1.1 Submitted By:   Soren Hvidbjerg
Report Type:  Basic functionality failure Date Reported:  5/27/2011 6:58:06 AM
Severity:    Serious / Highly visible problem Last Updated: 5/28/2011 5:19:51 PM
Platform:    All platforms Internal Tracking #:  
Resolution: Need More Info (Resolution Comments) Resolved in Build: : None
Duplicate of:  None
Voting and Rating
Overall Rating: No Ratings Yet
0.00 out of 5
Total Votes: 5
Description
The basic problem is described in <https://forums.embarcadero.com//thread.jspa?threadID=54578>
In short - you can't evaluate the value of a pointer in VS 2010. Two files are attached: A test project that you can run to reproduce the problem and a screen shot from VS 2010 that shows it.

Thanks
Soren Hvidbjerg

PS: Below is relevant version information taken from VS 2010's About box:

Microsoft Visual Studio 2010
Version 10.0.30319.1 RTMRel
Microsoft .NET Framework
Version 4.0.30319 RTMRel

Installed Version: Professional

Embarcadero Delphi Prism   4.0.25.791
Embarcadero Delphi Prism
Powered by the RemObjects Oxygene Compiler
Copyright ? 2008-2010 Embarcadero Technologies, Inc. All rights reserved.
All Embarcadero brand and product names are trademarks or registered trademarks of Embarcadero Technologies, Inc. in the United States and other countries. Oxygene is a trademark of RemObjects Software, LLC in the United States and other countries. All other marks are the property of their respective owners.
Steps to Reproduce:
None
Workarounds
None
Attachment
94337.zip
Comments

Tomohiro Takahashi at 5/27/2011 6:53:33 PM -
Could you please attach sample project(ncluding the screenshot) to this report?

Server Response from: ETNACODE01