Watch, Follow, &
Connect with Us

Please visit our new home
community.embarcadero.com.

Public Report
Report From: QualityCentral/Client Interface/Searching/Querying    [ Add a report in this area ]  
Report #:  10535   Status: Reported
QC changes system's decimal separator to point
Project:  QualityCentral Build #:  1.0.1.5
Version:    1.0 Submitted By:   Kjell Rilbe
Report Type:  Basic functionality failure Date Reported:  1/21/2005 5:23:12 AM
Severity:    Serious / Highly visible problem Last Updated:
Platform:    All versions Internal Tracking #:  
Resolution: None  Resolved in Build: : None
Duplicate of:  None
Voting and Rating
Overall Rating: (3 Total Ratings)
5.00 out of 5
Total Votes: 3
Description
When doing a query, QC changes the system setting for decimal separator to a point. In Europe, the decimal separator is a comma. This is clearly unacceptable.

I set the type and severity rather high, because while it's not a showstopper for QC itsels, it could actually cause a lot of problems if you do other work that relies on this setting to remain on comma, for example working with huge amounts of data in Excel, like I do.

Could we please have this fixed promptly?
Steps to Reproduce:
None
Workarounds
None
Attachment
None
Comments

Frederik Rosman at 1/25/2005 2:07:22 AM -
It cost us a lot of time to track this one back to QualityCentral, since the problem may not become apparent until hours after you used QC, so I agree completely with type/severity/motivation. It seems to happen right at startup of QC, even before a query is submitted.

Frederik Rosman at 4/9/2005 9:56:27 AM -
I do not get this problem anymore in 1.0.1.7, but it is not yet reported to be fixed.

Server Response from: ETNACODE01