Watch, Follow, &
Connect with Us

Please visit our new home
community.embarcadero.com.

Public Report
Report From: Delphi for PHP/IDE    [ Add a report in this area ]  
Report #:  109956   Status: Reported
IDE Toolbars are reloaded every 30 secs - IDE frozen
Project:  HTML5 Builder Build #:  4.4.0.1656
Version:    4.4 Submitted By:   John Schmidt
Report Type:  Issue Date Reported:  10/28/2012 8:00:17 AM
Severity:    Infrequently encountered problem Last Updated: 11/1/2012 6:17:28 PM
Platform:    All versions Internal Tracking #:  
Resolution: Cannot Reproduce (Resolution Comments) Resolved in Build: : None
Duplicate of:  None
Voting and Rating
Overall Rating: No Ratings Yet
0.00 out of 5
Total Votes: None
Description
The toolbars are reloaded every 30 secs with respective IDE freeze for 10 secs. I have reinstalled all several times but it doesn't help.

I use Windows 7 32bit.
Steps to Reproduce:
1. Run RadPHP XE2 with update 3a on Win7/32bit.
2. Uninstall all Win7 updates made the last two months.
3. Install RadPHP XE2 update 4
4. Start the IDE and try to customize the toolbars.
5. Save the customization and get the continous flickering/reloading.
Workarounds
None
Attachment
RADPHP.zip
Comments

Tomohiro Takahashi at 10/28/2012 6:08:27 PM -
I deleted QC#109957. Please do not post same reports.

John Schmidt at 10/29/2012 12:47:16 AM -
Sorry, I had to change that one inspite...

Tomohiro Takahashi at 10/28/2012 6:09:57 PM -
I have not ever seen the behavior.

What OS do you use, for example Windows 7 64bit etc...?

John Schmidt at 10/29/2012 10:29:23 AM -
I use Win7/32bit. Is there any need of a certain Wiin-DLL update level? Which DLLs?

I have done following (see steps which I have completed):  I had run RadPHP XE2 with update 3a without problems. Some days before installing update4 I have uninstalled all Win-updates of the last two months which have been made by the automatic updates. But I have no other application which would work strange.

I have verified this behavior of RadPHP XE2 on two Win7/32bit-machines, it's the same. You can imagine that ona cannot work with RadPHP XE2 this way at all.

Besides: There is no RadPHP selection any more thus I had to take HTML5 builder, sorry.

THERE ARE TWO SCREENSHOTS ATTACHED FOR YOUR CONVENIENCE!

Tomohiro Takahashi at 10/29/2012 5:39:56 PM -
ok, what Video card(and driver/version) do you use?

John Schmidt at 10/30/2012 12:44:26 PM -
1. machine: AMD Radeon HD 6310 Graphics, driver 8.892.0.0, date 2010.11.09
2. machine: ATI Mobility Radeon 3470, driver 8.635.0.0, date 2009.08.04

All has worked fine with these drivers until about two weeks ago. Graphical paint programs are working fine, MS Office 2010, Win7 Ultimate also.

Tomohiro Takahashi at 10/31/2012 12:52:13 AM -
Could you please try to update the drivers?
[Graphics Drivers & Software]
http://support.amd.com/us/gpudownload/Pages/index.aspx

John Schmidt at 11/1/2012 11:00:36 AM -
I have done so but everything remained as it was.

Please tell me how to uninstall RadPHP XE2 WITHOUT removing the license information! I think on all DLLs too,  but not those of the Delphi!!!

Tomohiro Takahashi at 11/1/2012 6:17:12 PM -
I advise you to contact technical support service for installation(standard) support.
http://support.embarcadero.com/

and, even if you uninstall RadPHP XE2, license information is not removed from the OS.

John Schmidt at 11/8/2012 4:20:38 AM -
The installation supporter tells that a clean uninstall/install needs to remove the license informations too by registry cleanup.

<<< ! >>> Meanwhile I have got the same issue with Delphi XE on Win7 32 and 64 bit too, see please my QC 110111. So I guess there must be a central problem with a too slow IDE refreshing there in the whole RAD Studio maybe.

If this helps you:

I have seen that the dropdown arrows for the <Run wihtout Debug> and <Run with debug> toolbarbuttons are no more visible inspite of 4 browsers added to the browsers list. This reminds me on API-DLL incompatibility.

Server Response from: ETNACODE01