Watch, Follow, &
Connect with Us

Please visit our new home
community.embarcadero.com.

Public Report
Report From: Delphi for PHP/Library    [ Add a report in this area ]  
Report #:  111677   Status: Need Feedback
Problem with accents in database
Project:  HTML5 Builder Build #:  XE2
Version:    4.0 Submitted By:   Dardo Schuster
Report Type:  Minor failure / Design problem Date Reported:  1/2/2013 11:18:13 AM
Severity:    Infrequently encountered problem Last Updated: 1/2/2013 8:17:25 PM
Platform:    All platforms Internal Tracking #:  
Resolution: Need More Info (Resolution Comments) Resolved in Build: : None
Duplicate of:  None
Voting and Rating
Overall Rating: No Ratings Yet
0.00 out of 5
Total Votes: None
Description
I have made an example in RadPHP XE2 using a DBGrid and MySQL database.
I want to put a Edit control and make a select with a Query component using a like clause to filter the data . When I use it with a AjaxCall, it works fine. But when in the database are fields with accents or another not conventional characters, it does not work.
What happens can anybody helpe me pleasesssss
Steps to Reproduce:
1. put a Database, a Query, a DataSource, a DBGrid, and a Edit control.
2. the idea is that when I write in the Edit control the query filter the data and show instantly the registers that fit the filter
Workarounds
None
Attachment
None
Comments

Tomohiro Takahashi at 1/2/2013 8:17:29 PM -
> ... fields with accents or another not conventional characters ...
Could you tell us more detail about it?

Server Response from: ETNACODE01