Watch, Follow, &
Connect with Us
Public Report
Report From: Delphi for PHP/IDE    [ Add a report in this area ]  
Report #:  111837   Status: Need Feedback
3 Autocomplete/Code-Completion Bugs
Project:  HTML5 Builder Build #:  5.1.167.137
Version:    5.0 Submitted By:   Michael Ainsworth
Report Type:  Crash / Data loss / Total failure Date Reported:  1/9/2013 9:58:07 PM
Severity:    Commonly encountered problem Last Updated: 1/10/2013 6:05:22 PM
Platform:    All platforms Internal Tracking #:  
Resolution: Need More Info (Resolution Comments) Resolved in Build: : None
Duplicate of:  None
Voting and Rating
Overall Rating: No Ratings Yet
0.00 out of 5
Total Votes: None
Description
The code completion / suggestion functionality has at least three issues.

Five screenshots attached, showing what happens during the typing process.

1. I've defined a member function of the current page called setAnimalsKeyFromPostData().
2. In a separate method, I try to call this method.
3. After typing "$this->", the autocomplete appears.
4. After typing "$this->setAnim", the built in "setAnimations()" code completion is shown.
5. After typing "$this->setAnimalsK", the suggestions are no longer filtered, and the entire list of suggestions is displayed, as in point 3 (image 1).
6. You can see that after typing the entire method name, the irrelevant suggestions are still being displayed.
7. As soon as I hit the '(' key (having typed "$this->setAnimalsKeyFromPostData"), the first suggestion replaces what I've already typed.

As I've already mentioned, there are three issues with the above.

1. At point 4 (image 2), I would expect the custom defined function to be part of the list of suggestions.
2. At point 5 (image 3), I would expect the list of suggestions to disappear.
3. At point 7 (image 5), I would expect what I've written to not be deleted by the IDE.

(I've left the steps section below blank, as the above explains the issue adequately, I believe. I have encountered a few other issues with code completion. I will post these too if I can spare the time).

I've listed this issue as "Data Loss" because it *erases* what you've already typed, rather than *completing* (i.e., appending) characters.

In terms of severity, I have listed this as "Commonly encountered" because although it's relatively minor, the frequency at which it occurs is very high.


IMPORTANT NOTE: I have been trying to add the attached images, but quality central itself is buggy (as I have previously noted). I will create a separate bug report for that, but if you'd like me to attach the images, you'll have to fix this issue first (and/or allow attachments to be added to comments).
Steps to Reproduce:
See the above.
Workarounds
I manage to get around this problem by remembering to close autocompletion (by hitting the "Escape" key), before hitting the final open bracked key.
Attachment
111837.zip
Comments

Michael Ainsworth at 1/9/2013 10:08:28 PM -
I've filed a bug report about not being able to upload attachments to bug reports.

Let me know when it's finished and I'll provide you with the screenshots.

http://qc.embarcadero.com/wc/qcmain.aspx?d=111838

Michael Ainsworth at 1/10/2013 3:32:33 PM -
I've just now been able to upload an attachment.

It contains the 5 screenshots of the autocompletion bug.

Tomohiro Takahashi at 1/10/2013 6:05:31 PM -
Please try my [Steps] to re-attach a .zip file
1. please download QC client from
  http://qc.codegear.com/qualitycentral.zip
2. launch QulaityCentral.exe and look up your existing report
3. activate [Attachments] tab
4. select all files
5. show popup menu
6. select [Remove Attachment]
7. show popup menu again
8. select [Add Attachment...]
9. select a .zip file

Server Response from: ETNACODE01