Watch, Follow, &
Connect with Us

Please visit our new home
community.embarcadero.com.

Public Report
Report From: Delphi for PHP/Library    [ Add a report in this area ]  
Report #:  118088   Status: Open
DBRepeater doesn't work with Firebird images
Project:  HTML5 Builder Build #:  5.1.167.137
Version:    5.0 Submitted By:   Paco Ruiz
Report Type:  Basic functionality failure Date Reported:  8/22/2013 5:01:41 AM
Severity:    Serious / Highly visible problem Last Updated: 8/24/2013 6:40:47 AM
Platform:    All platforms Internal Tracking #:   5025
Resolution: None (Resolution Comments) Resolved in Build: : None
Duplicate of:  None
Voting and Rating
Overall Rating: No Ratings Yet
0.00 out of 5
Total Votes: None
Description
I have configured a connection to a Firebird database.
I use a table with a varchar field and a image/blob field.

My form has a DBRepeater with a label and a image component to get both fields data.
When I run the application, I get all names but always the first image.

Like ...
- John - [image1]
- Jane - [image1]
- Fran - [image1]
...

I have made other tests (first-while not eof-next) reading the data from the table and I get images ok,
but image component doesn't work in DBRepeater
Steps to Reproduce:
None
Workarounds
None
Attachment
dbrepeater_error.zip
Comments

Tomohiro Takahashi at 8/23/2013 12:33:07 AM -
Could you please attach sample project(with sample database file) to reproduce/confirm your issue?
and, What version of Firebird do you use?

Does your issue occur only with Firebird? What about other RDBMS?

Paco Ruiz at 8/23/2013 1:17:14 AM -
Sorry, how do I attach a file?

Firebird 2.1.3.18185
Sorry, I don´t use any other RDBMS.

Tomohiro Takahashi at 8/23/2013 8:44:27 AM -
Please use Windows Native QC client to attach a .zip file to your existing report.
The standalone client is available at this URL.
http://qc.codegear.com/qualitycentral.zip

Paco Ruiz at 8/23/2013 9:23:20 AM -
Done

Server Response from: ETNACODE01