Watch, Follow, &
Connect with Us
Public Report
Report From: Delphi-BCB/IDE    [ Add a report in this area ]  
Report #:  133666   Status: Open
Git integartion not working with Delphi 10 Seattle
Project:  Delphi Build #:  23.0.20618.2753
Version:    21.0 Submitted By:   Mark Rogers
Report Type:  Basic functionality failure Date Reported:  9/17/2015 10:53:08 AM
Severity:    Critical / Show Stopper Last Updated: 10/19/2015 6:33:17 AM
Platform:    All platforms Internal Tracking #:   70337
Resolution: None (Resolution Comments) Resolved in Build: : None
Duplicate of:  None
Voting and Rating
Overall Rating: No Ratings Yet
0.00 out of 5
Total Votes: None
Description
NOTE: I have used XE7 as there is no Delphi 10 Seattle in the list box.

Major Git integration issues where it is not possible to clone, pull or push in the initial instance.  But can once a push has been done via a external utility such as GitBash.  Committing to the local repository works fine.  

For full details and steps on how the problems are re-created please see the attached document
Steps to Reproduce:
For full details and steps on how the problems are re-created please see the attached document
Workarounds
None
Attachment
133666.zip
Comments

Mark Rogers at 9/17/2015 11:00:32 AM -
To clarify the description.
I am unable to clone or pull a remote repository. I am also unable to push a remote repository in the initial instance.  However once the local has been pushed for the first time by an external utility such as GitBash. I can do further pushes with no issues.  But clones and pulls are still not possible from within the IDE.

Juan Antonio Ruzafa at 10/19/2015 6:28:38 AM -
Hi,
Please use https://quality.embarcadero.com/secure/Dashboard.jspa to report bugs for RadStudio Seattle

Server Response from: ETNACODE01