Watch, Follow, &
Connect with Us

Please visit our new home
community.embarcadero.com.

Public Report
Report From: JBuilder/Startup/Launchers    [ Add a report in this area ]  
Report #:  26987   Status: Reported
JBuilder 2006 launchers does not work on XP 64 with default vmmax value
Project:  JBuilder Build #:  12.0.203
Version:    12 Submitted By:   Doychin Bondzhev
Report Type:  Basic functionality failure Date Reported:  4/4/2006 10:47:35 PM
Severity:    Infrequently encountered problem Last Updated:
Platform:    64-bit Windows 2000 Internal Tracking #:  
Resolution: None  Resolved in Build: : None
Duplicate of:  None
Voting and Rating
Overall Rating: (1 Total Rating)
5.00 out of 5
Total Votes: 1
Description
WIth default values in jbuilder.config for memory jbuilder won't start on XP 64. I haven't tested this on XP but I suspect that it will work with default startup options and won't work with /3G option

I have 2 GB RAM on AMD 64 system with XP 64.

Also I have noticed that if I comment the line from vmmax JBuilder can start and also after that if I remove the comment it will start again until I restart the operating system.

WHen I run form command line I get a message that there is not enought memory for system heap.

In order to avoid this I just put 768m as value instead of 75% for vmmax.
Steps to Reproduce:
Install on clean XP 64. Try to run it. the splash screen becomes visible (wihtout versio info) and then suddenly disaperars.
Workarounds
to set value different from 75% for vmmax and less then 1G.
Attachment
None
Comments

None

Server Response from: ETNACODE01