Watch, Follow, &
Connect with Us
Public Report
Report From: JBuilder/Team Development    [ Add a report in this area ]  
Report #:  29263   Status: Reported
Problem when using Subversion with SVN_ASP_DOT_NET_HACK
Project:  JBuilder Build #:  12.0.206
Version:    12 Submitted By:   Pontus Amberg
Report Type:  Basic functionality failure Date Reported:  5/19/2006 1:42:24 AM
Severity:    Infrequently encountered problem Last Updated: 5/23/2006 9:38:12 AM
Platform:    All versions Internal Tracking #:  
Resolution: None  Resolved in Build: : None
Duplicate of:  None
Voting and Rating
Overall Rating: (1 Total Rating)
3.00 out of 5
Total Votes: 1
Description
It looks like the SVN_ASP_DOT_NET_HACK ( http://subversion.tigris.org/faq.html#vs-asp-net ) confuses JBuilder when it tries to place a project into Subversion. This is probably only affecting a very small portion of JBuilder users who is also working with .NET stuff.

This is the output when placing the project in subversion

Importing...
Pulling from http://subversion/svn/projects/test/trunk...
Checked out revision 2.
Finished pulling from http://subversion/svn/projects/test/trunk
Adding project's files to repository...
Error importing project Test.jpx

This is the failing command from the console

"C:\Program Files\Subversion\bin\svn.exe" add -N --targets C:\DOCUME~1\pa\LOCALS~1\Temp\pttemp43761svn

And here's the error message

svn: '_svn' is not a working copy
Steps to Reproduce:
1. Set the environment variable SVN_ASP_DOT_NET_HACK as explained here http://subversion.tigris.org/faq.html#vs-asp-net
2. Start JBuilder
3. Try to place a project into Subversion
Workarounds
Remove the SVN_ASP_DOT_NET_HACK from the environment variables and restart JBuilder.
Attachment
None
Comments

None

Server Response from: ETNACODE01