Watch, Follow, &
Connect with Us
Public Report
Report From: JBuilder/Components    [ Add a report in this area ]  
Report #:  46395   Status: Reported
Unable to find a supported JDK or JRE version
Project:  JBuilder Build #:  JBuilder 2005
Version:    11 Submitted By:   Kevin Cahn
Report Type:  Basic functionality failure Date Reported:  5/22/2007 1:19:54 PM
Severity:    Critical / Show Stopper Last Updated: 12/7/2007 7:24:48 AM
Platform:    All versions Internal Tracking #:  
Resolution: None  Resolved in Build: : None
Duplicate of:  None
Voting and Rating
Overall Rating: (1 Total Rating)
3.00 out of 5
Total Votes: None
Description
I receive the following error when trying to run a Windows executable created using JBuilder:

"Unable to find a supported JDK or JRE version.  Version 1.3.1 or higher is required."

The error also occurs if I run the executable JAR file created using JBuilder.  

The code runs from within JBuilder.  I can also build and run the code from outside of JBuilder using ANT.  Note that this problem does not occur when using JBuilder X.  I recently upgraded from JBuilder X to JBuilder 2005 and loaded the latest JDK (1.5.0_11) in order to be able to use generics.

I set both the default project properties and project properties to use the new JDK.  I also set the language features to use "Java 2 SDK, v5.0 (generics enabled)" and the Target VM to "Java 2 SDK, v 1.3 or higher".  

If I type Java -version from the command line, I get "java version 1.5.0_11", which is the expected version.
Steps to Reproduce:
N/A
Workarounds
None known
Attachment
None
Comments

None

Server Response from: ETNACODE01