Watch, Follow, &
Connect with Us

Please visit our new home
community.embarcadero.com.

Public Report
Report From: JBuilder 2007/EJB3    [ Add a report in this area ]  
Report #:  66033   Status: Need Feedback
Jbuilder 2008 - Import Entities from Database
Project:  JBuilder 2007 Build #:  1.2.2
Version:    2007 1.0 Submitted By:   Ian Steigrad
Report Type:  Basic functionality failure Date Reported:  8/24/2008 7:20:14 PM
Severity:    Commonly encountered problem Last Updated: 9/5/2008 9:32:22 PM
Platform:    Windows Vista Internal Tracking #:  
Resolution: Need More Info (Resolution Comments) Resolved in Build: : None
Duplicate of:  None
Voting and Rating
Overall Rating: No Ratings Yet
0.00 out of 5
Total Votes: None
Description
This is actually an issue in Jbuilder 2008 which I have logged here as there is no tab for JB2008 at present (see item 66029).

I am trying to import Entities from an SQL Server 2005 Database. I have made the connection between Jbuilder and the Database and can use Datasource Explorer to browse through the coonection to the schema to the tables successfully.

when I right-click on the EJB3 Modeler Project and go to "import entities from database" the importer wizard starts. The first dialog shows the database connection correctly but no schemas. It doesn't seem to matter what DB connection settings I use, I can't get the Schema to display and, consequently I cant get to the tables to import the entity structure.

I really have no idea how to configure this importer function and why it would have difficulty in seeing the schema event though I can see it in Datasource Explorer.
Steps to Reproduce:
In descritpion above.
Workarounds
Cant find one - I have just manually coded all the entities which is very tedious indeed!
Attachment
None
Comments

Tomohiro Takahashi at 8/25/2008 1:23:32 AM -
Please try to select "Reconnect..." link in the Wizard dialog to activate your DB connection.

If possible, please attach screenshot of the wizard.

Server Response from: ETNACODE01