Watch, Follow, &
Connect with Us
Public Report
Report From: Delphi-BCB/AddOn/RAVE    [ Add a report in this area ]  
Report #:  67499   Status: Closed
Rave AVs on open
Project:  Delphi Build #:  12.0.3170.16989
Version:    12.0 Submitted By:   Bill Todd
Report Type:  Crash / Data loss / Total failure Date Reported:  10/3/2008 10:28:03 AM
Severity:    Commonly encountered problem Last Updated: 3/20/2012 2:24:39 AM
Platform:    All versions Internal Tracking #:   266189
Resolution: Fixed (Resolution Comments) Resolved in Build: : 7.6.1 BE
Duplicate of:  None
Voting and Rating
Overall Rating: No Ratings Yet
0.00 out of 5
Total Votes: 1
Description
I installed D2009 only (not C++ Builder) on XP Pro SP3 and took all of
the defaults. When I try to start Rave from the main menu I
get the standard Windows dialog with the message:

Rave.exe has encountered a problem and needs to close.

When I click the Don't Send button I get:

Excption EAccessViolation in module rtl120.bpl at 0001D760.
Access violation at address 5001D760 in module 'rtl120.bpl.
Read of address 0020002F.

Starting Rave from inside the IDE produces the same AV. I did a
complete uninstall and reinstall and still get the same
result. I have enquired of my TeamB colleagues and I am not the only
one with this problem.

I installed D2009 only (not C++ Builder) and took all of
the defaults. When I try to start Rave from the main menu I
get the standard Windows dialog with the message:

Rave.exe has encountered a problem and needs to close.

When I click the Don't Send button I get:

Excption EAccessViolation in module rtl120.bpl at 0001D760.
Access violation at address 5001D760 in module 'rtl120.bpl.
Read of address 0020002F.

Starting Rave from inside the IDE produces the same AV. I did a
complete uninstall and reinstall and still get the same
result. I have enquired of my TeamB colleagues and I am not the only
one with this problem.

Steps to Reproduce:
Start  Rave. Note that this AV only affects some users.
Workarounds
None
Attachment
None
Comments

Tomohiro Takahashi at 10/5/2008 6:28:28 PM -
Let me comfirm your environment.
In you PC, how many printers are setup(intalled)?
It seems that Rave fails to start if two or more printers exist.
So, please try to reduce the nubmer of printers and make sure only 1 printer exists.

Søren Bech Christensen at 12/2/2008 10:21:33 PM -
When is there going to be a solution to this issue?
I Agree with Mike, that reducing the number of installed printers to one, would not be an acceptable solution.
I only know 5 people who have installed D2009 and all have this issue with Rave, so it is not an isolated problem.
Personally I will soon have to look for another reporting solution, if this is not resolved.
Remember: We are paying customers and a major part of the package just doesn't work.

Mike Kershaw at 10/28/2008 7:46:07 AM -
This will not fix the problem, I reduced the number of printers on one of my machines to test this and Rave still AV's.  Even if this did sort the problem out, this would not be an acceptable long term fix. I have an application which has been deployed where removing printers is absolutely not an option.

Tomohiro Takahashi at 12/16/2008 10:02:15 PM -
Please check your issue with update version.
---
Rave Reports 7.6.1 BE for Delphi 2009 and C++Builder 2009
Updated version of Rave Reports from Nevrona Designs
Available only to registered users of Delphi 2009, C++Builder 2009 and RAD Studio 2009
http://cc.codegear.com/item/26089
---

Søren Bech Christensen at 12/18/2008 11:35:52 PM -
This new update works for me : Heureka !!! Now I can start using RAD Studio 2009.

Tomohiro Takahashi at 12/23/2008 9:14:08 PM -
Thanks for confirmation.

Server Response from: ETNACODE01