Watch, Follow, &
Connect with Us
Public Report
Report From: JBuilder/Debugger/Remote Debugging    [ Add a report in this area ]  
Report #:  73077   Status: Need Feedback
Websphere 6.1 remote debug in JBuilder 2006
Project:  JBuilder Build #:  latest
Version:    12 Submitted By:   Valeriy Trokhimchuk
Report Type:  Crash / Data loss / Total failure Date Reported:  4/17/2009 11:16:34 PM
Severity:    Serious / Highly visible problem Last Updated: 4/19/2009 8:30:15 PM
Platform:    All versions Internal Tracking #:  
Resolution: Need More Info (Resolution Comments) Resolved in Build: : None
Duplicate of:  None
Voting and Rating
Overall Rating: No Ratings Yet
0.00 out of 5
Total Votes: None
Description
I can initially connect to the debug port and set a break point, but after some steps in the code IDE becomes unresponsive.
WebbSphere Application Server version - 6.1.0.23
Debug parameters in WebSphere debug service settings:
-Xdebug –Xnoagent-Djava.compiler=NONE Xrunjdwp:transport=dt_socket,server=y,address=3999,suspend=n (Many other combinations have been tried).
Steps to Reproduce:
None
Workarounds
None
Attachment
None
Comments

Tomohiro Takahashi at 4/19/2009 8:30:02 PM -
AFAIK, JBuilder2006 supports WebSphere 6.0, but does not support 6.1.

Doychin Bondzhev at 4/19/2009 9:24:27 PM -
It is not supported but It can be used with it.

Question to Valeriy: Do you have JAD installed to decompile java code in JBuilder?

Valeriy Trokhimchuk at 4/20/2009 10:56:04 AM -
Yes, I have a JAD on my computer.

Doychin Bondzhev at 4/20/2009 1:20:20 PM -
When you reach the point where JBuilder freezes open task manager and look for jad.exe process. If you have such process probably you are trying to step in into JRE/JEE code and IDE tries to decompile the class. There are cases where jad can't decompile properly some classes and freezes.

Another problem for freezing is that there are some problems when debugging multi-thread applications. In some cases JRE or JBuilder debugger freezes in such cases.

Server Response from: ETNACODE01