Watch, Follow, &
Connect with Us
Public Report
Report From: Delphi for PHP/IDE/Other    [ Add a report in this area ]  
Report #:  77385   Status: Reported
deployed code is difeerent working than in IDE
Project:  HTML5 Builder Build #:  2.1.0.1098
Version:    2.0 Submitted By:   Christian Gnoth
Report Type:  Basic functionality failure Date Reported:  9/5/2009 4:28:26 AM
Severity:    Commonly encountered problem Last Updated: 9/9/2009 11:14:45 PM
Platform:    All versions Internal Tracking #:  
Resolution: None (Resolution Comments) Resolved in Build: : None
Duplicate of:  None
Voting and Rating
Overall Rating: No Ratings Yet
0.00 out of 5
Total Votes: None
Description
Hello,
I have the problem that the generated <form> tag is different in the deployed application that the tag generated from the IDE.

inside the IDE the <form> tag has as action=/businesschart.php and in the deployed version action=/index.php which does not exists.
Steps to Reproduce:
I used the Tools->Deployment Expert.
Workarounds
None
Attachment
businesschart.zip
Comments

Tomohiro Takahashi at 9/6/2009 6:01:32 PM -
I can not reproduce your issue.
Could you please write more detailed Steps and attach the simplest sample project to reproduce your issue?

> ... <form> tag is different ...
and please provide more information about the difference.

Christian Gnoth at 9/8/2009 8:51:46 AM -
Hello,

I came a step forward wioth this.

I tried to implement the Delphi appl inside of the CMS Wordpress.

If I try to implement it native - the generated form tag is like:

<form action="/index.php" .....>


If I call the appl inside the IDE the form tag is like:

<form action="/businesschart.php" ....>

therefore each button click is fowarded to businesschart.php as the appl's name.



Now I have put the whole appl inside a iform and it is working. The generated HTML form tag has as action the "bsuinesschart.php".

Is there the possibility to give over a parameter the action to the appl?

Server Response from: ETNACODE01