Watch, Follow, &
Connect with Us
Public Report
Report From: EDN/Discussion Forums/NNTP interface    [ Add a report in this area ]  
Report #:  82519   Status: Open
"Empty" email address in the NTTP From header is handled incorrectly.
Project:  EDN Build #:  beta
Version:    2 Submitted By:   Pieter Zijlstra
Report Type:  Minor failure / Design problem Date Reported:  2/26/2010 5:51:31 PM
Severity:    Infrequently encountered problem Last Updated: 7/23/2010 10:11:03 AM
Platform:    All platforms Internal Tracking #:  
Resolution: None (Resolution Comments) Resolved in Build: : None
Duplicate of:  None
Voting and Rating
Overall Rating: No Ratings Yet
0.00 out of 5
Total Votes: None
Description
When a NNTP newsclient does not specify an email address it causes the server to copy/use the complete from-header as an email-address
which is then added to the logged-in user display name.

When posting the following message using NTTP which doesn't specify an email address:

[tx] POST
[rx] 340 send article to be posted. End with <CR-LF>.<CR-LF>
[tx] From: "PZ Bo" <>
[tx] Subject: Re: Test
[tx] etc

the post apears as:

[rx] From: Pieter Zijlstra <"PZ Bo" <>>
https://forums.embarcadero.com/thread.jspa?messageID=216909&tstart=0#216909
("Pieter Zijlstra" is my "display-name" as setup in the members area"


When posting a message by using the web-forum (with an hidden email address) it appears as:

[rx] From: Pieter Zijlstra <>
https://forums.embarcadero.com/thread.jspa?messageID=216899&tstart=0#216899


I'm not discussing the fact that the From header is not respected as described in report #65491, part of me does understand why you do this,
this reports is about how posts, not specifying an email address,  are treated by this server compared to posts made by using the web-forums
(from a user with a hidden email address).
Steps to Reproduce:
None
Workarounds
None
Attachment
None
Comments

None

Server Response from: ETNACODE01