Watch, Follow, &
Connect with Us
Public Report
Report From: Delphi-BCB/VCL/Ribbon Controls    [ Add a report in this area ]  
Report #:  93023   Status: Reported
Access violation - closed the application without saving, Used the Ribbon controls
Project:  Delphi Build #:  15.0.3953.35171
Version:    15.1 Submitted By:   Scott van der Linden
Report Type:  Crash / Data loss / Total failure Date Reported:  4/12/2011 7:13:01 PM
Severity:    Infrequently encountered problem Last Updated: 4/15/2011 5:27:03 PM
Platform:    All platforms Internal Tracking #:  
Resolution: None (Resolution Comments) Resolved in Build: : None
Duplicate of:  None
Voting and Rating
Overall Rating: No Ratings Yet
0.00 out of 5
Total Votes: None
Description
Access violation at address 5035AB77 in module 'vcl150.bpl'. Read of address 00000008.

Used the Ribbon controls
Steps to Reproduce:
To an existing application on an existing form with existing controls on the form (saved etc):

1. Added a Ribbon, action manager and image lists (1 for each action manager hook).
1.1 Attached the image lists to the action manager, and the action manager to the ribbon.
1.2 Added a ribbon and groups to each ribbon.
1.3 Added a bunch of actions in the action manager and drag-and-dropped them into some of the groups.
1.4 inexplicably the actions weren't turning into buttons when I dragged them (I can't explain this, and after a reboot of Delphi it started working so who knows what is going on with that!)
2. Added a project to the project group
3. Added a ribbon, action manager and image list.  
3.1 Attached the image lists to the action manager, and the action manager to the ribbon.
3.2 Added a ribbon and groups to each ribbon.
3.3 Added a bunch of actions in the action manager and drag-and-dropped them into some of the groups.
4. closed the application without saving (no save at all)
Error!  Now the ribbon in the original app brings up this error

Note: I save all state data between delphi sessions - I don't know if that is important.
Workarounds
None
Attachment
Report.zip
Comments

Scott van der Linden at 4/13/2011 3:48:35 PM -
This happened again!  All I did was close the project group that had an app with a ribbon on the main page and the page was open.

Note: I use the classic delphi layout.

Tomohiro Takahashi at 4/13/2011 9:05:59 PM -
Have you already installed any 3rd-party plugin?

And, if possible, could you please provide more concrete [Steps] to reproduce your issue?

Scott van der Linden at 4/14/2011 9:14:43 PM -
I have no 3rd-party plugins (other than those that come installed with Delphi XE).

Server Response from: ETNACODE01