Watch, Follow, &
Connect with Us
Public Report
Report From: Delphi-BCB/IDE/Code Browsing    [ Add a report in this area ]  
Report #:  96492   Status: Reported
Ctrl+Click is highly unreliable
Project:  Delphi Build #:  15.0.3953.35171
Version:    15.1 Submitted By:   David Howes
Report Type:  Basic functionality failure Date Reported:  7/21/2011 10:20:22 AM
Severity:    Commonly encountered problem Last Updated: 7/22/2011 3:56:36 PM
Platform:    All platforms Internal Tracking #:  
Resolution: None (Resolution Comments) Resolved in Build: : None
Duplicate of:  None
Voting and Rating
Overall Rating: No Ratings Yet
0.00 out of 5
Total Votes: 5
Description
Ctrl+click on anything, e.g. variables, classes or whatever, when the item you are navigating to is in another file and the action can fail. The failure results in either nothing happening at all, or the wrong position being jumped to in the external file.
Steps to Reproduce:
Just work with ANY large project to see this happen. Usually navigation will work correctly for a while and then fail after that. It's difficult to be any more specific than that as there seems to be no real pattern.
Workarounds
Closing the project and re-opening will normally cause navigation to start working properly again for a while.
Attachment
None
Comments

Tomohiro Takahashi at 7/21/2011 9:12:44 PM -
> Build No: 7601
What build no of Delphi XE do you use? Have you already applied all of Updates/Hotfixes?

David Howes at 7/22/2011 12:28:38 PM -
sorry (posted the windows build # by mistake),

build# 15.0.3953.35171

I have sp1 installed. This is confirmed in the 'installed updates'

No hotfixes as far as I recall. None showing in the 'Installed Updates' box.

I do have GExperts installed. However the problems was definately present BEFORE I installed GExperts. I installed GExperts in the hope that I could easilly delete all the dynamically generated files such as identcache etc. I had heard that had solved the problem for some people.

The size of the project I am working on is around 200,000 lines of code. When I work with smaller projects I don't seem to get the error.

This issue was present for this in project in Delphi2006, and was still present when I migrated to 2007. It is obviously still present now in XE. This would seem to rule out regression errors introduced post Delphi 2006.

It really would be good if you could sort this issue as it seems to get worse the larger the project size. Obviously the bigger the project, the more important code navigation is!

Please don't hesitate to ask if you need more information. I really would like to see this fixed. It's so bad that I frequently can only work for 5 to 10 minutes at a time before needing to close and re-open the project.

Tomohiro Takahashi at 7/22/2011 3:56:30 PM -
> The size of the project I am working on is around 200,000 lines of code.
Ok, could ou please contact technical support service for more investigation? Sorry for inconvenience.
http://support.embarcadero.com/

David Howes at 7/22/2011 6:54:07 PM -
I can't do that I don't have a support contract. As far as I know I just qualify for installation and registration support.

Server Response from: ETNACODE01